Manjaro Tools

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category No Category
  • Assigned To No-one
  • Operating System Manjaro
  • Severity High
  • Priority Very Low
  • Reported Version 0.13.8
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Manjaro Tools
Opened by luca - 24.05.2017

FS#198 - Temperatures going dangerously high when charging USB type C device in a skylake system

Hi, I’ve got a DELL XPS 15 9550 which has a Thunderbolt 3 USB Type C port.

I’ve recently bought a typec to c cable to charge my phone, but when I plug it, it charges only for a few seconds, then no sign of life from the cable. But the kernel seems not to be happy with it, and also the temperatures.
The “sensors” command reported after a few minutes a temperature of 60c° from “pch_skylake-virtual-0” and NOT from the GPU or CPU, so it can probably be a sort of I/O controller, and that is a very high temperature.

I’m using linux kernel 4.11.1-1-Manjaro. I honestly don’t know how to report this to upstream kernel developers.

dmesg in the attachment, you can see when I plugged the cable in the end

   dmesg.zip (19.1 KiB)
luca commented on 24.05.2017 23:57

DMESG plain text file

luca commented on 25.05.2017 00:02

Please note that when on sleep mode is just charges correctly, so that can't be a defective cable.

luca commented on 25.05.2017 10:49

SOME UPDATES The temperature problem is an upstream bug, or just normal. Idk.
But i've tried ARCHLINUX and UBUNTU and the phone DOES charge. Also tried different kernel versions

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing